Failure

Started
November 17, 2020 at 12:28 PM
Status
Investigating
Affected
Signaling

Impact

Major outage
  • Investigating
    November 17, 2020 at 12:28 PM

    SmartEyes website unreachable